Using Visualize Schedule

Project Gateway Agent Graphics has replaced the Visualize Schedule
function for most users. The command is retained for existing users
familiar with it.

Using the Visualize functions, you can prepare attractive Gantt charts of
your project schedules that are displayed by the included Charts Now
graphing utility. The Charts Now! on-line help contains complete
information on using the application as a standalone tool. This chapter
discusses its use in conjunction with Project Gateway.

The Visualize Schedule Command

The Visualize command uses the Charts Now! application to present a
Gantt chart of the project with the most up to date information in the
database.

Visualize Schedule Dialog

Selecting the Visualize Schedule command from the Tools menu
displays the familiar select database dialog, preset to the current
database, the one last used for Record, Create, Make or Synchronize.

?: Server: |Lucal j|

d:\notes\datatmanual

Databaze Title: |[..]

Database
Project Title: Pm'ecl Gateway Sample j|
[ Multiproject Summary
oK I Cancel | Help |

If you want to access a different database, select the server first, then
click on the database title.
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Note: If your server name does not appear in the dropdown list, you may
enter it manually in the Server field.

Since Project Gateway databases can contain more than one project, the
“Database Project Name” field allows you to choose which project is to
be exported. The field displays the “Click Here...” prompt. When you
click it, a drop list will appear showing the names of all projects in the
database. Click on the desired project title to select it.

If you have not already selected a project in the database, the Database
Project Title field will drop down when you press OK. You must select
a project before proceeding, however, if there is only one project in the
database, the system will automatically select it for you

Once selected, Project Gateway will display a progress dialog as it
retrieves the Field Map and the StoredProjectModel. Then it reads the
assignment documents, updates the project and displays the Visualize
Options Dialog.

Multiproject Summary Option

Selecting this option removes the Database Project Title list box from
the display. It causes the system to generate a special Gantt chart that
shows one schedule bar for each project in the database. When selected
the visualize options dialog is not shown. On this chart, each project
appears as a summary bar, below it appear all the key events of that
project. If InterProject dependencies are defined, they appear as
connecting links between the key events.

Visualize Options Dialog

& Include All Project Tasks

" Include Only Assignments For: Cancel |
| [All] j| Help |
Options
Bar Style v Include Summary Tasks
3D Bar j [” Show dependencies links
[" Double Space v Show Zcomplete

The radio buttons at the upper left allow you to chart the entire project
(the default) or only those tasks assigned to a particular resource. To
use this feature, check the Include Only option and select the resource
name from the drop down list.

The Options setting in the lower panel controls what information is
generated and how it will appear.
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The list box selects the bar style: 3D, Drop Shadow, or Plain.

Include Summary tasks directs the creation of Gantt bars for "summary *
tasks found in the project plan. Summary tasks are used to organize and
group the work into logic sections and most project planners make use
of them. When checked, summary tasks in the plan will be displayed as
annotation symbols in the chart. If not checked, only individual tasks
will be shown.

Show dependency links. This adds directed arrows to the chart to show
the planned sequence of events. Only Finish to Start linkages are
shown.

Show % Complete. This shades the bars in proportion to the percent
complete reported for the task. Note that a task with several
assignments will show the average percent complete for the
assignments.

Double Space. This adds space between rows in the chart. Will result
in more attractive displays for projects with only a few tasks.

Note: The color of Gantt bars and text is specified on the Project
Gateway/Setting Dialog.

When you OK this dialog, Charts Now! will be launched and will
display the chart.
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Charts Now! Operation

General Information

Charts Now! has two views, a Chart view and a Symbol view. The
Symbol View is a spreadsheet-like table showing all the elements of the
chart. By double clicking on object in either the Chart or Symbol Views
you will display a dialog of the detailed information for that item.
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When Charts Now! is launched by Project Gateway, the Toolbar and
Symbol palette are not displayed. You can display them by using the
View command.
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Selecting Symbols

All symbol (i.e. task bar) related commands, such as Move Symbols,
Copy Symbols, and Delete Symbols, operate on one or more selected
symbols. The button bar property selectors also work on selected
symbols. Multiple symbol selection is a powerful feature that lets you
make changes just once to an entire group of symbols. This saves work
and speeds the editing process.

For example, suppose you want to change the font typeface for a group
of symbols. Simply select each symbol you want to change and then
select a new typeface. Each selected symbol is immediately updated
with the new typeface.

To select a single symbol:
1. Move the cursor over the desired symbol.

2. Press the left mouse button. The symbol's color changes to
white, indicating the symbol is selected.

To select multiple symbols:
1. Move the mouse cursor over a desired symbol.

2. Pressthe SHIFT key and the left mouse button simultaneously
(Shift-Click). The symbol's color changes to white, indicating
the symbol is selected.

3. Repeat the previous steps for each additional symbol.
To select a range of symbols:
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1. Move the mouse cursor to the upper-left of the area to be
selected.

2. Press the left mouse button and drag the mouse while holding
down the left mouse button. A bounding rectangle appears
showing the area to be selected.

3. Release the left mouse button. All symbols falling in the
selected area change to white, indicating the symbols that have
been selected.

To select all symbols:

From the Edit menu, choose Select All. All symbols on the chart
change to white, indicating they have been selected.
Unselecting Symbols

After completing a symbol operation, you can unselect the selected
symbols before selecting others for new symbol operations.

To unselect symbols one-by-one:
1. Move the mouse cursor to the desired symbol.

2. Press the SHIFT key and the left mouse button simultaneously
(Shift-Click). The symbol's color changes from white back to
its normal color, indicating the symbol is no longer selected.

3. Repeat these steps for each symbol that you want to unselect.

To unselect all symbols on the chart, select the Unselect All command
from the Edit menu. All selected symbols change to their individual
symbol colors, indicating they are no longer selected.

Formatting The Selected Items

The Format menu commands will change the appearance of the items
selected.

Changing Symbol Styles, Fonts, and Colors

There are two ways to set symbol shapes, fonts, and colors for the chart
objects: the Button Bar and the Symbol dialog box. The Button Bar is
the most convenient way to quickly change a property for one or more
symbols. The Symbol dialog lets you change these display properties as
well as enter note text and adjust the symbol's start date and duration.

To change the symbol shape, font, or color using the button bar:
1. Select one or more symbols.

2. Use the mouse to select a typeface, font size, justification, color,
or symbol shape from the button bar controls. The new
property is applied to all selected symbols.

3. (Optional) Choose the Edit | Unselect All command to deselect
the symbols. You may postpone this step if you wish to make
further property style changes to the selected symbols. You can
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also use the Format | Style dialog box to change the style for
one or more symbols.

Shape

Choose from over 45 different symbol shapes. Note that the bit map and
text shapes will appear as blank unless there is a bit map or text present
to display.

Text Justification

The name and notes displayed in a symbol can be left, center, or right
justified.
Text Placement

The symbol name and notes can be displayed inside the symbol and also
in various positions around the box. Placing text outside the box is
useful for milestones, where the text normally appears to the right of the
milestone. This feature is also useful for displaying a long name that
will not fit inside the symbol.

Sizing

Symbols can automatically size themselves to fit the name or notes
displayed inside the symbol. A symbol can automatically grow itself
vertically or horizontally as designated. Automatically expanding a
symbol horizontally is useful for milestones, which do not have a

duration. Expanding vertically is useful for annotations that display
long notes.

A symbol can also shrink the font size of the displayed text until all of
the text fits inside the symbol. This is useful for symbols whose size or
duration cannot be changed and where it is important to display all of
the text within the symbol.

Formatting The Chart
Note: Printing is not supported in the Project Gateway Edition.
Legend

The Legend dialog box is used to enter user-defined symbol field names.
There are three user-defined fields that appear on the Task dialog box.
The field names entered on the Legend dialog box appear to the left of
the user-defined fields on the Task dialog box. These field names are
also used on the Filter dialog box for use in selecting a subset of symbols
for display on the chart.

Layout

The Format | Layout dialog designates which scale is displayed at the
top of the chart area and other options.

Scale

Charts Now! has three different scales: the time scale, an inches ruler,
and a centimeter ruler. The time scale is typically used for Gantt and
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PERT charts, while the inches and centimeter rulers are used for
network diagrams, flow charts, organization charts, and other types of
diagrams that aren't time related

The time scale has a variety of different date and time formats and is
printed as part of the chart. When the Time Scale is selected on the
Layout dialog, the Format pull-down menu will have a Time Scale
command. When either the Inches or Centimeter rulers are selected on
the Layout dialog, the Format pull-down menu will have a Ruler
command instead of a Time Scale command.

Show Percentage Complete

The Show Percentage Complete option alters the display of symbols by
showing the portion of each symbol that has been completed differently
from the incomplete portion. When this option is enabled, the
completed portion of each symbol is shown normally. The incomplete
portion of the symbol is shown with a diagonal hatched line. The
percentage complete is calculated from the Completed Duration field on
the Task dialog box for each symbol.

Show Links

The Show Links option enables the display of links between symbols.
Turning the Show Links option off removes the symbol links from
display. Turning Show Links off does not remove or delete the symbol
links it merely hides them from view.

Turning the Show Links option off is a convenient way to hide the
sometimes cluttered set of symbol links. This is especially important
when preparing a report for management that is only interested in the
schedule and not the assumptions leading to the schedule. It also makes
scrolling much faster.

Copying The Chart To The Clipboard

Charts Now! uses a special Edit | Copy Image to Clipboard command to
copy a chart image to the Windows clipboard.

The Copy Image to Clipboard dialog lets you select the portion of the
chart you want transferred.

After the chart image has been copied to the Windows clipboard, it is
available for all other applications to paste into their documents or files
as appropriate. In most applications, the image transfer is completed
using an Edit | Paste command in the destination application.

Charts Now! creates a bit map image of the chart on the Windows
clipboard.

Start Date, End Date

Select the date range to be copied to the clipboard. This allows you to
selectively copy portions of the schedule to the clipboard.
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